Off Road Forums On Planet4x4 banner

1 - 10 of 10 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Have been Racking our brains over here on this one for a while now....

Lets catch those that have not been following this rigs story up to speed.. Last year when i bought the short bus I retired the My blazer to mundane duty of daily driver for the old lady my god have mercy on its soal.. R.I.P. LOL
she drives it 127 miles a day... well about 6 months into it.. it blew the 700 r4 with 200K miles on the origional trans,,, big supprize right,,, well had it rebuilt,,,

well here is where things get wierd...

well its been acitng funny like its been fuel starved.. so basicly over the last month the entire and i do mean entire fuel system has either been replaced with new or reman parts from tits to tail i have 500+ bucks in the fuel system in this sucker hell the injectors were 300 alone... last night we thought we had her licked with the replacement of the fuel pump .. nope....

so here is what she is still doing...

she bogs off the line but then after a bog and a spudder she will burn the tires for about 20 ft,,, and run fine.... woo hooo,,, bog bad tire burning power good,,, but why bog??????

second thing REAL BAD<<<<<

going down the road either at a stop light or sitting in a parkinglot just dies....


or better yet going down the freeway,, cruise set,,, 1800 rpm.... wife was in the truck for the first time it ever did this...IT WILL GO BANG then buck and shimmy rpms will drop to nothing then jump back up,,, go for a sec BANG drop back down go back up this will repeat for a few seconds,, just enough to freak ya out realy good then it will stop then

and best of all its all completely random and it THROWS NO CHECK ENGINE CODES SO IT CANT BE READ!!!!





so here is a list of whats been replaced or at least checked satisfactory,
Cap
rotor
plugs
wires
coil
Destrib ---was replaced last year,,,,,
new injectors and all acc gaskets and stuff
new filters
New fuel pump
New fuel tank sending unit


possible culprits??????
Map sensor?
TPS?
Pick up coil in distrib?
distrib in general?
Maby slight chance of arcing of plug wires aginst somting but didnt see a cracked boot????

i doubt its fuel related..... anymore LOL :mrgreen: that solved alot of its problems


i realy dont wana have to pay for this SOB to have to go to the darn dealer .......

i know i could have gone carb cheaper but its the wifes dd and she wants f/i "reliability" *gasp *spudder besides with wa new governer signing new smog laws i would have to swith it back soon anyway ,,, i didnt vote for her...


so does anybody have any idea's????
i am open for just about any shots in the dark other than shooting it or lighting it on fire LOL
 

·
Registered
Joined
·
397 Posts
lets see some pics of what you are building
 

·
Going Postal
Joined
·
4,026 Posts
My money is on timing in some manner. I had an 80's blazer that did the same kind of thing and it turns out the plug into the distributer was bad ( computer controlled advance) and it would loose advance and pop sometimes.



Planet | 4X4 | Forum
 

·
Registered
Joined
·
3,268 Posts
i'd go with the timing as well.... with that many miles, I bet that chain has just a wee bit of stretch to it..
 

·
Wrench Wench
Joined
·
6,190 Posts
I start with the thing always overlooked on these engines, failure of the EGR. The EGR is on whenever you put it into gear, and the backpressure and vacuum on the engine regulate it. I have done more than one that ran ok at idle in park, ok and idle in gear, but give it between 1000 and 2000 rpms and she spits and sputters all over...... Just pull the line and plug it, see if it makes a difference, you'll know right off the bat if it does. Then make sure to REPLACE it, it is important in keeping combustion chamber temps down while cruising down the road.

Timing is a great check to make at the same time too!



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #6 ·
Egr huh I will give that a check for 38 bucks why the heck not...

but check this i was doing some research on hi milage tbi problems .... and some people complain on similar issues... to me have

TBI worn out throttle shaft that could explain some things?? what do you guys think??? could that lead me somwhere of would that be an expensive wild goose chase???
 

·
Registered
Joined
·
190 Posts
im with lumpdog on this one it well could be the egr we had a 94 blazer and it did the same thing you are saying your 92 does. if i were you i would check to see if you need the electrical one over the macanical one becuase the elcectric one cost some where in the range of 140 a big price change from the macanical one thats just my .02 cents
 

·
Registered
Joined
·
167 Posts
hey just wanted to say my old 94 blazer was like that too turned out to be the trans wasn't rebuilt right. :banghead:
 

·
Registered
Joined
·
545 Posts
My money say's they put the wrong torque converter in. Take it back to the tranny shop and nicely raise enough of a fuss that they replace it with the right one.
 
1 - 10 of 10 Posts
Top