Off Road Forums On Planet4x4 banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I jump started someones car last night, it was a quick and easy ordeal but afterwards things started going crazy in my jeep. at idle my voltage stays a constant 14 if you dry rev the engine OUT of gear the voltage stays where it should.
If you turn any electronics on in the jeep voltage drops to nine, lights stay dim and the engine shudders.

Driving away brings the voltage down to nine or below with or without anything on. after a hundred feet or so the engine will lose all electrical power and stall out. Restarting the engine and allowing it to idle will slowly bring the voltage back up to 14 where you can drive another 100 feet and you will die again. I already tried replacing the battery, the alternator did pass a test at idle and load reporting 14.6 volts at the battery.

What could the problem be, did i short a relay or something that is bleeding positive juice into the frame? I have no idea any and all help would be great.

:(Broken XJ in Rexburg!
 

·
Registered
Joined
·
1,887 Posts
What year XJ?
 

·
Going Postal
Joined
·
4,026 Posts
My money's on the alternator. Sounds like the voltage regulator has gone bad.

You could go and check all the connections though before anything else, sometimes they get gunked up and actually start acting like little capacitors and that will drop voltage here and there.



Planet | 4X4 | Forum
 

·
Registered
Joined
·
74 Posts
Make dang sure your battery terminals are clean and tight, also the lead from your alternator. Any time you turn something on and the current goes up, your voltage goes down. You have a corroded connection somewhere.
 
1 - 5 of 5 Posts
Top