Off Road Forums On Planet4x4 banner
1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
I finally got time to put a 3" lift kit on my 86' Jeep XJ. The Wildcat EXTs with the new black Allied D wheels I've got on there look sick compared to the originals. I hope I can post some pictures of it soon. It looks really good with the new coat of mud I just applied to it.

I am selling the original wheels for it they are 15x7s.

They are a little chipped and they still have some of the 19 years worth of grime that I wasn't able to get off, but overall they are in pretty good shape. I'll have pictures of them on here soon, too.

I don't know how much I should sell them for. I don't know how much these original wheels go for. I also have 3 original Jeep hubcaps, only got 3 cause I lost 1 some how, they are usually stuck on there pretty good. That must be the reason I could never find any at the junkyard.

Does anybody know if these originals have any value?

If they dont then I'll just throw them in with the wheels free-of-charge.

If your interested in buying the wheels send me a PM and I'll get back to you as soon as possible.

Thanks,

Mike
 

·
Registered
Joined
·
9 Posts
What kind of lift are you running? I have an RE 3.5" superflex, it looks awesome, but my driver's side coil keeps getting shit under it and then it squeaks like crazy. I would like to know if this is a problem that you have too or is it just my rig or lift.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
I'm running a 3" BDS lift. Bigger coils in the front, small add-a-leafs in the rear and 1.25" Extended Shackles.

I don't have that problem.

What kind of rig do u have?
 

·
Registered
Joined
·
9 Posts
I have a '94 XJ with a 4.0 and AX15, 231 w/ SYE, I run 31x10.50 Wildcat EXTs and the above mentioned lift.

The first time the squeak stared was when I was testing the flex on it and the driver's side coil became unweighted. After the weight of the vehicle was on the coil again it was squeaking. Now it squeakd everytime the I hit a bump or even accelerate fast; I don't think it is hurting anything but my ears.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #5 ·
You might have a bad coil bushing.
 
1 - 6 of 6 Posts
Top