Off Road Forums On Planet4x4 banner

1 - 10 of 10 Posts

·
Going Postal
Joined
·
4,026 Posts
Discussion Starter · #1 ·
Went to fix the leak and found the top of the case broken! :angryfir:

Gonna be close for Moab. :angryfir:



Planet | 4X4 | Forum
 

·
Going Postal
Joined
·
4,026 Posts
Discussion Starter · #3 ·
Who knows. I've got it out now and should be getting another rebuilt unit tomorrow late in the day. I'm going to have a busy week in front of me.

Man, that tranny worked great. :(



Planet | 4X4 | Forum
 

·
Going Postal
Joined
·
4,026 Posts
Discussion Starter · #5 ·
Yep! Got the new tranny in Today and I'm back on Schedule. I do want to see the Lower Proving grounds. :thumb:



Planet | 4X4 | Forum
 

·
Registered
Joined
·
14 Posts
i know where u are coming from. i had the same thing happen to my TH350, but mine cracked down near the pan. i had one in a parts truck and i am currently getting it built.
 

·
Registered
Joined
·
3 Posts
GateCity4x4 said:
Went to fix the leak and found the top of the case broken! :angryfir:

Gonna be close for Moab. :angryfir:
Did you check all your mounts, tranny and motor????
 

·
Going Postal
Joined
·
4,026 Posts
Discussion Starter · #8 ·
fumes said:
GateCity4x4 said:
Went to fix the leak and found the top of the case broken! :angryfir:

Gonna be close for Moab. :angryfir:
Did you check all your mounts, tranny and motor????
Its all good. I think its related to the power output/ Tire size with the 4:11 gears that I used to run. I broke several transfer case adapters this last summer as well as blowing up a few drivelines. What I've done now is go to 5:13 gears wich should help unload the drivetrain some and I've added an extra mount off of the side of the transfere case over to the frame.

Got my fingers crossed. :mrgreen:



Planet | 4X4 | Forum
 

·
Registered
Joined
·
63 Posts
That is really bad, but it sounds like you fixed the problem in like no time at all... very impressive, hope all goes well and it stays fixed this time...
 
1 - 10 of 10 Posts
Top